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TUTORIAL MACROMEDIA DREAMWEAVER

• Mengenal tampilan dreamweaver
• Mendefinisikan Local site site
• Membuat halaman baru
• Membuat tabel,frame dan layer
• Memasukkan  gambar
• Membuat rollover image
• Memasukkan flash button dan teks button
• Mendeteksi browser yang dipakai pengunjung
• Membuat jump menu
• Mengecek link pada website
• Mengupload pada server
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1. Mengenal Tampilan Kerja Dreamweaver

Berikut ini penjelasan untuk elemen-elemen workspace seperti telah tertera pada gambar :

Ø Document Window adalah tempat membuat halaman web secara visual, kode, atau
keduanya.

Ø Document Toolbar berguna untuk mengubah tampilan dari design/visual view, code
view, atau keduanya sekaligus. Selain itu juga untuk memberi titel pada dokumen,
melihat tampilan di browser.

- Pada  tag selector menampilkan HTML control pada text atau object yang
dipilih. jika diklik salah satu text atau object maka pada tag selector akan
tampak HTML control, contoh klik  pada dokumen window, pada tag selector
akan tampak tulisan <body> disini menunjukan kita sedang bekerja pada body
dari dokumen secara HTML.
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- Pada document toolbar ditunjukkan judul halaman. Bila file belum disimpan
akan terdapat tanda (*) pada title bar.

- Status bar, didapat pada bagian paling  bawah document window,menunjukkan
informasi-informasi tentang dokumen yang sedang dibuat.

- Mengatur ukuran window. Pada status bar di dokumen window menampilkan
dimensi atau ukuran window saat itu (dalam  pixel). Jika ukuran window ini
diklik, Dreamweaver menampilkan menu window size pop-up, dimana ukuran
yang cocok dapat diatur sesuai dengan monitor yang digunakan. Untuk
mendesain sebuah halaman pada  ukuran spesifik yang terbaik, dapat dipilih
pada ukuran yang sudah ditentukan, mengatur ukuran yang sudah ditentukan itu
sesuai dengan keinginan atau membuat ukuran baru.

- Catatan : Pada ukuran window  menggambarkan ukuran dimensi pada browser.
Untuk contoh, ukuran yang digunakan “536 x 196 (640 x 480,default)”  jika
pengunjung situs  menggunakan Microsoft Internet Explorer atau Netscape
Navigator, maka konfigurasi tampilan mereka 640 x 480.

Ø Insert panel adalah tempat memasukan image, Flash movie, table, atau elemen lain.
Insert panel ini serupa dengan menu Insert pada menu bar. Untuk memunculkan panel
ini, klik Windows > Insert atau tekan Ctrl-F2.

Ø Property Inspector berguna untuk melakukan pengeditan pada suatu elemen di
Document Window.

Ø Panels Group merupakan kumpulan dari panel-panel Dreamweaver.

2. Mendefinisikan website
Ø Setelah masuk ke dreamweaver, dari menu Site, pilih New Site.
Ø Pada bagian Site Name, tuliskan nama web. Sedangkan Local Root Folder adalah

tempat yang akan digunakan untuk menyimpan semua file untuk web yang dibuat,
temasuk file image, video, audio, javascript dll.

Ø http addres diisikan alamat website, dimana semua file web akan di upload nantinya.
Ø Setelah selesai akan muncul halaman baru, panel group pada multitap file akan

menunjukkan lokasi tempat semua file website disimpan
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Ø setelah mendefinisikan site (baik online atau offlne), dapat dilakukan pengkonfigurasian
ulang. Yaitu dari menu site>>manage site

Ø untuk website online langsung dengan host server, nama site biasanya diawali dengan
ftp://, yang kemudian untuk mengkonfigurasi diperlukan koneksi secara online dengan
server. Misalnya untuk ftp://html (merupakan lokasi file untuk website hmk di server
host UB), untuk masuk kedalam server host tersebut, harus login terlebih dahulu dengan
mengisi konfigurasi server yang ada.
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3. Membuat halaman baru
Ø Membuat dokumen HTML kosong baru : pilih menu  File > New.
Ø Untuk membuka file HTML yang sudah ada : pilih menu File > Open
Ø Membuat dokumen baru berdasarkan template :

•  Pilih menu File > New from Template. Akan tampak dialog box, daftar template-
template yang ada (template dibuat terlebih dahulu sebelum membuat dokumen baru
berdasarkan template)
•  Pilih salah satu template. Dokumen baru akan dibuat berdasarkan template tersebut.

4. Membuat tabel, frame dan layer
TABEL

Untuk membuat dan memodifikasi
tabel pada dreamweaver, ada
beberapa cara, yaitu:
Ø Pilih menu Insert >> tabel
Ø tekan shortcut : Ctrl+Alt+I
Ø atau pada insert panel kategori

common, pilih Tabel
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Masukkan spesifikasi tabel yang diinginkan pada kotak dialog Tabel.
- Isikan jumlah baris pada “Rows” dan jumlah kolom pada “Columns”.
- Tentukan lebar tabel terhadap halaman. Jika lebar tabel dalam satuan pixel (fixed

size),isikan jumlah pixel pada Width. Lebar tiap kolom nantinya dibagi sama rata dari
lebar tabel dan bisa di ubah-ubah sesuai keinginan. Jika berlebar persen, gantilah kotak
dropdown yang bertuliskan Pixel menjadi Percent. Misalnya “Width : 75 Percent” yang
artinya lebar tabel  nantinya adalah 75 persen dari lebar halaman.

- Berikutnya, masukkan lebar border tabel yang diinginkan dalam satuan pixel. Jika
dikosongi maka dianggap 0 (nol) dan tabel tidak diberi border.

- Jika diinginkan, masukkan Cell  Padding dan Cell Spacing. Cell Spacing artinya jarak
antar sel dalam tabel, sedangkan Cell Padding artinya jarak dari border sel sampai
dengan isi sel.

- Jika ingin memodifikasi ulang tabel, dapat dilakukan dengan mengganti – ganti value
pada tabel property, yang biasanya terletak dibawah document window.

FRAME
Frame ialah cara untuk menampilkan beberapa halaman HTML dalam satu jendela browser.
Yaitu dengan membagi-bagi satu jendela browser menjadi beberapa bagian, dimana tiap bagian
menampilkan halaman HTML yangberbeda-beda. Untuk bekerja dengan frame, harus dibuat
satu halaman baru sebagai  frameset. Dimana di dalam  frameset ini terdapat beberapa halaman
HTML untuk ditampilkan. Jadi, satu  frameset bisa mengandung beberapa halaman
HTML.Selama bekerja dengan frame, alangkah baiknya bila  toolbar frame dalam keadaan
aktif. Caranya, klik menu  Window,   Frame (atau  Shift+F2). Sedangkan Object Properties juga
sebaiknya dalam keadaan aktif (menu Window, Properties atau Ctrl+F3). Untuk memasukkan
frame, pada insert panel kategori layout >> pilih Frame.
Ø Mengubah properti-properti frame

Untuk mengubah properti frame, secara sederhana dapat dilakukan dengan mengaktifkan frame
yang akan diubah propertinya. Kemudian, lihat pada window  Object Properties. Tampak
properti-properti yang dimiliki oleh sebuah frame.
Penjelasan :
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- Frame Name adalah nama dari frame yang sedang aktif. Nama frame ini penting untuk
dicatat karena dapat digunakan untuk membuat link lintas frame.

- Src adalah nama file sumber dari frame yang sedang aktif. Untuk mengubah halaman
yang ditampilkan, dapat mengganti properti Src dengan salah satu file HTML yang
telah dibuat.

- Scroll untuk menentukan apakah frame yang sedang aktif akan diberi scrollbar ataukah
tidak. Jika dipilih Auto, maka  scrollbar diberikan hanya jika dokumen tidak dapat
ditampilkan dalam satu layar sehingga diberikan scrollbar.

- No Resize : Jika dalam keadaan ter-cawang, maka frame tidak bisa di-resize oleh user.
Sedangkan jika tidak dalam keadaan ter-cawang,maka frame dapat di-resize oleh user.

- Borders menentukan apakah frame diberi border.
- Border Color menentukan warna dari border frame
Ø Mengubah properti-properti frameset
Untuk mengubah properti  frameset, aktifkan dahulu frameset-nya. Kemudian properti
dapat diubah pada Object Properties.

Penjelasan :
- Borders menentukan apakah semua frame diberi border.
- Border Width menentukan lebar border
- Border Color menentukan warna border
Ø Mengubah ukuran dan menghapus frame

- Untuk mengubah ukuran frame, secara sederhana dapat dilakukan men-drag batas frame
ke arah horizontal atau vertikal sampai ukuran yang diinginkan tercapai.

- Untuk menghapus frame, dapat dilakukan dengan men-drag batas frame sampai ke luar
Document Window.
Ø Save semua frame

Yang perlu diingat dalam bekerja dengan frame yaitu sebelum mem-preview hasil
pekerjaan, perlu dilakukan penyimpanan semua frame yang telah dibentuk. Caranya, klik
menu File, kemudian Save All Frames. Maka akan diminta untuk memberi nama file
untuk  frameset beserta frame-frame yang ada di dalamnya.
Ø Membuat link antar frame

Sebelumnya kita telah pelajari mengenai link dan hyperlink, dimana  link dan
hyperlink  digunakan untuk menunjuk ke dokumen atau file lain. Link berguna untuk
membawa user ke halaman lain atau men-download suatu file. Sebenarnya, suatu link
dapat ditentukan apakah akan dibuka di jendela browser yang sama, jendela browser yang
baru,  atau dibuka di frame lain. Pada contoh ini, kita akan mencoba membuat link antar
frame, dimana link akan dibuka di frame lain. Misalkan tersedia sebuah  frameset
(index.htm) dan di dalamnya terdapat 2 frame yaitu “leftFrame” (menu.htm) dan
“mainFrame” (utama.htm). Kemudian, kita ingin membuat sebuah link di leftFrame, yang
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mana link tersebut akan dibuka di mainFrame. Maka, buatlah link di sebelah leftFrame
seperti biasa,kemudian lihat pada Object Properties.

Gantilah properti  Target menjadi nama frame tujuan yang diinginkan (mainFrame).
Sebagai tambahan, pilihan _blank berarti link dibuka di jendela browser baru, pilihan
_parent berarti link dibuka di frameset paling pertama,pilihan  _self berarti link dibuka di
frame dan jendela browser yang sama, pilihan _top berarti link dibuka di frameset satu
level diatas frame yang aktif, dan sisanya adalah nama-nama frame yang terdapat dalam
halaman tersebut (jika terdapat 2 frame atau lebih dalam satu halaman). Dengan
menggunakan frame, kita dapat membuat halaman navigasi sendiri dimana seluruh link
dibuka di frame utama. Dengan demikian, user dapat menghemat waktu karena tidak
perlu mendownload menu navigasi berkali-kali setiap mengakses halaman lain.

 Layer

Layer merupakan salah satu keunggulan Dreamweaver
dibandingkan dengan editor HTML lainnya. Dengan layer, kita
dapat membuat halaman HTML yang tampilannya lebih
fleksibel. Layer digunakan untuk menampilkan objek dengan
posisi yang dapat diatur-atur  sesuka kita, tanpa terbatas pada
pandangan baris-demi-baris. Analoginya,  layer diumpamakan
sebagai plastik transparan yang dapat diletakkan dimana saja di
atas kertas. Selama bekerja dengan layer, alangkah baiknya
apabila window  Layers dalam keadaan aktif. Caranya, klik
menu Window, kemudian Layers.
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Untuk memasukkan layer pada frame atau document
window, dapat dilakukan dengan memilih insert panel pada
kategori layout, kemudian pilih  Draw Layer.dalam satu
dokumen, dapat dimasukkan lebih dari satu layer. Namun
perlu diingat bahwa semakin banyak layer maka semakin
besar pula dokumen. Setelah memasukkan layer ke dalam
dokumen, maka window Layer akan menampilkan status
dari semua layer yang ada di dalam dokumen.
Penjelasan :

- Prevent Overlaps, berarti setiap layer yang ada akan dilarang untuk saling tumpang
tindih.

- Tabel di dalam window  Layers menampilkan semua layer yang ada pada dokumen.
Urutannya yaitu dimulai dari yang paling atas sampai dengan paling bawah. Layer
yang terletak di  atas layer yang lain, akan ditampilkan lebih di atas (lebih kelihatan).

- Kolom bergambar mata, menandakan layer apakah terlihat atau tidak. Kolom Name
menandakan nama layer, dan kolom Z menandakan ketinggian layer. Semakin besar
Z, maka layer akan ditampilkan semakin terlihat (menutupi layer-layer lain dengan Z
lebih kecil). Untuk mengubah urut-urutan ini, dapat men-drag layer ke atas atau ke
bawah atau mengubah nilai  Z yang dimilikinya.

Ø Mengaktifkan layer
Untuk mengaktifkan layer, dapat dilakukan dengan mengklik pada Controller layer

yang bersangkutan, atau mengklik pada pinggiran layer yang bersangkutan.
Ø Memindahkan dan mengubah ukuran layer

Untuk memindahkan layer, aktifkan dulu layer yang diinginkan. Kemudian drag
pinggiran layer ke tempat yang diinginkan. Untuk mengubah ukuran layer, dapat men-drag
salah satu kotak di pinggiran layer sampai ukuran yang diinginkan tercapai.
Ø Mengubah properti-properti Layer

Untuk mengubah properti layer, dapat dilakukan dengan mengaktifkan dahulu layer
yang dinginkan, kemudian lihat pada Object Properties.
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Kita akan membahas sebagian saja dari Layer Properties ini.
• Properti  L menandakan posisi horizontal layer terhadap pinggir kiri dokumen
• Properti  T menandakan posisi vertikal  layer terhadap bagian atas dokumen
• Properti W menandakan lebar layer
• Properti H menandakan tinggi layer
• Z-index adalah urutan layer
• Vis adalah visibility, dimana jika default atau visible, maka layer akan terlihat.

Sedangkan bila  invisible, maka layer tidak terlihat. Dan jika inherit, maka layer
akan menuruti sifat layer induknya. Bila layer induk visible maka ia juga visible.
Begitu pula sebaliknya.

• Bg Image adalah gambar latar belakang dari layer
• Bg Color adalah warna latar belakang dari layer

Ø Mengisi objek ke dalam layer
Untuk mengisikan objek ke dalam layer,  klik kiri mouse di atas layer yang diinginkan.
Kemudian mulailah mengetik atau memasukkan gambar, table, dan objek-objek lain.

5. Memasukkan Gambar
Terdapat 2 cara untuk memasukkan image pada Dreamweaver , dengan menggunakan main
menu dan dengan menggunakan Object panel.

Ø Pilih menu Insert > Image (Tampak dialog box untuk memilih  file image, jika
salah satu image diklik maka akan terlihat preview dari image tersebut. Untuk
memilih/memasukkan image, klik select à semua file image yang digunakan
dimasukkan dalam satu folder)

Ø cara kedua : pada insert panelà  kategori common, pilih image

6. Membuat Rollover Image
Rollover image adalah suatu image yang akan berubah ketika  pointer dari mouse diarahkan
pada image tersebut. Rollover image terdiri dari 2 gambar atau image: image pertama akan
tampak pada saat kita pertama kali loading browers, dan image kedua akan tampak ketika
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pointer diarahkan pada image tersebut. Pastikan kedua image tersebut ukuran yang sama, bila
tidak sama maka tampilan site tampak tidak teratur. Untuk memasukkan  rollover Image : pada
insert panel à  kategori common, pilih image à rollover image. maka akan tampak dialog
box rollover image yang harus diisi,dialog box ini untuk memilih image pertama dan memilih
rollover image atau image kedua (sebelumnya harus  sudah menyiapkan image-image tersebut),
alamat url atau link yang dituju bila image tersebut diklik.

Ø Pastikan mencentang option Preload image rollover, untuk memastikan image rollover
tersebut jalan bila dibrowse. Klik OK untuk menutup dialog box tersebut bila sudah
selesai.

Ø Hasilnya tidak akan dapat melihat hasil  rollover image tersebut dalam tampilan
dokumen window ;  rollover image hanya akan tampak pada  browser, sebelum
dipreview dibrowser tidak perlu menyimpan (save) dokumen anda terlebih dahulu.

- Tekan F12 > akan terlihat dokumen tersebut pada web browser. Arahkan pointer
pada image tersebut, maka akan tampak image yang berubah-ubah.

- Ketika selesai melihat  file tersebut dalam tampilan  browser, tutup window
browser tersebut.

- Kembali dokumen pada Dreamweaver, pilih menu File > Save untuk menyimpan
file tersebut.

7. Memasukkan flash button dan flash text
Pada Dreamweaver, diberikan kemudahan dalam mendesain website yang dinamis dengan

adanya button-button menu pada tampilan dokumen site. Macromedia Dreamweaver dapat
langsung memasukkan Flash Button yang sangat dinamis dan animasi dalam berbagai macam
bentuk.
Ø Untuk memasukkan  flash button : pada insert panelà  kategori common, pilih Mediaà

Flash Button. Maka akan keluar sebuah  dialog box, yang harus diisi, dengan memilih
bentuk-bentuk button, menulis teks dan jenis hingga ukuran teks yang akan ditampilkan
pada button tersebut, memasukkan alamat halaman lain (link).

Ø Untuk memasukkan  flash button : pada insert panelà  kategori common, pilih Mediaà
Flash text. Maka akan keluar  dialog box yang harus diisi  properties dari teks (jenis teks,
ukuran, align, dan sebagainya), hampir sama dengan rollover image, flash text dapat
disebut rollover text. Tetapi hanya warna dari teks tersebut yang dapat berubah (rollover).
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- Pastikan option  show font tercentang, untuk memastikan textrollover tersebut jalan bila
dibrowse.

- Klik OK untuk menutup dialog box tersebut bila sudah selesai.
- Hasilnya  tidak akan dapat melihat hasil rollover image tersebut dalam tampilan dokumen

window ;  flash text hanya akan tampak pada  browser, tidak perlu menyimpan (save)
dokumen anda terlebih dahulu.

• Tekan F12 > akan terlihat dokumen pada web browser. Arahkan pointer pada image
tersebut, maka akan tampak image yang berubah-ubah.

• Ketika anda selesai melihat file tersebut dalam tampilan browser, tutup window
browser tersebut.

• Kembali dokumen anda pada Dreamweaver, pilih menu File > Save untuk menyimpan
file

8. Mendeteksi browser yang dipakai pengunjung
Pendeteksian browser yang digunakan pengunjung sangat berguna untuk memberikan

tampilan yangsesuai dengan browser pengunjung tersebut, sehingga website yang kita design
sedemikian rupa bisa terlihat rapi atau tidak berubah saat digunakan dengan browser yang
berbeda – beda (karena dapat dilakukan penyesuaian). Cara pendeteksian browser yang
digunakan pengunjung adalah sebagai berikut :
Ø Dari menu windows, pilih behavior (atau tekan F8), tekan tombol   lalu

pilih show event foràIE 4.0. dan tekan lagi tombol terseut pilih check browser
Ø Maka akan keluar dialog box check browser. Jika yang digunakan adalah NN 4.0 ,aka

… terdapat 3 pilihan. Yaitu: stay on this page, Go To URL dan Go to Alt URL. Jika
yang dipilih adalah stay on this page,  maka haaman tersebutlah yang akn ditampilkan
jika pengunjung web memakai NN 4.0 dan sebaliknya,  pada bagian IE 4.0 harus
mengisi dengan Go to URL dan pada bagian URL harus diisi dengan halaman web yang
aka ditampilkan jika pengunjung memakai I.E 4.0
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9. Membuat jump menu
à contoh Jump Menu

menu ini biasanya digunakan sebaga navigasi yang akan
“mengantar” pengunjung website untuk menuju halamn yang lainya. Dengan Macromedia
Dreamwever kita dapat membuat jump menu  dengan mudah. Caranya sebagai berikut :

Ø Insertà Formà Jump Menu
Ø Pada bagian Text, ketik item yang akan dimunculkan pada menu list, pada bagian

Ehen selected Go To URL pilih file yang akan dibuka (atau link). Setelah selesai klik
tombol “tambah” dibagian atas.

Ø Jika diinginkan tombol GO, maka centang pada Insert Go Button After Menu
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10. Mengecek link pada website
Jika ingin dilakukan pengecekan link pada satu halaman html. Pilih menu file à check

page à check link (atau dengan shortcut shift+F8). Sedangkan jika ingin dilakukan
pengecekan dari semua halaman web dari keseluruhan halaman website yang telah dibuat, pilih
menu siteà check link sitewide (atau dengan shortcut shift+F8).

Waktu yang diperlukan untuk pengecekan broken link tergantung dengan banyaknya
halaman yang terdapat pada website, tentunya semakin banyak halaman website yang ada maka
akan membutuhkan waktu yang lama dalam pengecekannya.

Untuk melakuka perbaikan pada broken link, pilih file yang terdapat pada result. Kemudian
browse pada file directory tempat file yang akan di-lik-kan tersipan.

11. Mengupload pada server
ini adalah langkah terakhir dan yang  terpenting dalam pembuatan suatu website. Jika

sudah menyelesaikan desain web, maka harus dilakukan proses upload ke server agar website
yang sudah dibuat dan desain dapat tampil di brower internet. Pada contoh berikut ini
digunakan filezile untuk mengupload file. Langkah-langkah yang harus dilakukan ialah :

§ Buka program filezile, maka akan tampak interface software, seperti dibawah ini :
§ Tuliskan address, username serta passwordàquickconnect


